Receipt Processing for DDs issue

Minor incident Payments Hub DD Collections
2025-09-01 11:47 BST · 21 hours, 37 minutes

Updates

Resolved

Technical Teams managed to resolve the issue at 4:30pm on 01/09/2025.

September 2, 2025 · 09:24 BST
Monitoring

Please be advised, we’re continuing to work with our third party to investigate the delay in the receipt processing for this morning’s Direct Debit (DD) files. While we are actively replaying the files and expect to deliver the receipt later today, this will exceed the usual 12pm SLA. We’ll share a further update once resolved. Thank you for your patience.

September 1, 2025 · 12:44 BST

← Back