Intermittent Payments hub login

Major incident Payments Hub Portal Funtionality Send Pin NHS Portal Reports OTP DD Portal Access DD Collections
2025-10-02 15:24 BST · 1 hour, 23 minutes

Updates

Resolved

After a period of monitoring we can confirm resolution

October 6, 2025 · 09:06 BST
Monitoring

Technical teams are happy service is restored and monitoring further. we apologise for inconvenience caused.

October 2, 2025 · 16:39 BST
Investigating

02/10/2025 16:00 Technical teams are seeing services come back operational. Further monitoring and work commencing at this stage.

October 2, 2025 · 15:57 BST
Issue

02/10/2025 15:15pm Technical teams are currently investigating an intermittent outage on payments hub platform. Further updates to follow.

October 2, 2025 · 15:24 BST

← Back